Skip to main content

Has anyone ever used the TWAIN driver successfully with a 1060? I sold a 1060 to a client who wanted to use the system's high-speed scanning ability with a software package that was specific to their industry. The client's only stipulation was that the $1,000 scanning software add-on to her current software package required a TWAIN driver. I told her "no problem" and she purchased the scanning add-on and I delivered the 1060. Now, I can't get the TWAIN driver to work with the 1060. I have tried it with every scanning software I can think of. I have tried it on two different 1060's. I have tried it on Windows 2000 and XP laptops with crossover cables. We have called Ricoh Tech Services and were told that the TWAIN driver needed NetBEUI running on the network, but this hasn't worked for me either. Now Tech Services is telling us that we need to post a "Tech Alert" because they have never heard of this problem (I'm afraid this is their way of putting me on the back burner). I find it hard to believe that I am the only person to has tried to use the TWAIN driver with this system, but no matter what I do, I still keep getting an error message that says the scanner cannot be found (even though all of the software packages can "see" the 1060 as a scanning option...they just can't find it when actually trying to scan). Anyone with any thoughts or success stories?


Original Post

Replies sorted oldest to newest


The client's software is supposed to work with the network connection, but I am pretty sure that this has nothing to do with their software. I am getting the same error message when using the TWAIN driver in my office when scanning from Illustrator, Publisher and even simple Microsoft Imaging. I am pretty confident that this is a problem with the TWAIN driver and not any specific software issue.

Thanks for the quick response. I am setting up the third 1060 for testing purposes in my demo room as we speak.

I have had success with scanning utilizing a Twain driver on a 1060. Here are some things to consider.

Personal Firewall Software may be blocking communication on the port that Twain uses to communicate...XP for example has a built-in firewall that will block ports used for various service communications...Port 1022 is used for Twain communication....You can check to see if your pc is "Listening" on 1022 by running netstat -a at a command prompt...

Try disabling SNMP on the network interface...I have seen this protocol do some strange things in regards to scanning...
If I'd have thought about it more, I would have said the same thing. I had a customer that had the internal Firewalls turned on in XP, and nothing would work. I could have enabled the ports as Bill indicated or disabled the personal firewall. They chose the later and everything now works fine. Let us know what you find out incase it is something different. Who knows, one of us may run across this in the future.
Thanks again for the help guys, but you're not going to believe what I found. The latest version of the driver is the problem. When my IT department does an install, they always download the "latest and greatest" versions of all software and drivers from the website. This time all I had to do to get this to work was to use an older version of the TWAIN driver (version 3.33). I tested this today while installing a 1060 on the network of another client that was already running NetNEUI and it worked, so I am not yet sure that my client with the original problem won't have to run NetBEUI also (Ricoh Tech Services said they would, but my IT guys are not excited about using NetBEUI), but I'll find out tomorrow. I also wanted to let you know that my Service Mgr. found the same thing you guys did concerning XP and the firewalls, but the client is running 2000 Pro and there were no firewalls to bypass. But at least I'll know what to look for next time when it won't work on an XP workstation!

Thanks for all the quick responses and I'll keep you posted on the final outcome.
Wow... I thought I was the only person who discovered these "new" problems.

Yes, it does seem suspicious that you are the first person reporting the problem, but a "Tech Alert" really is the best way to go. This will require tech support to actually attempt to duplicate your issue and issue you a written response on what they found.

Of course, on the last one they sent to me they flat-out lied on the written response and I caught them red-handed. They said they tested a feature, but when I called them back and got a supervisor on the phone and MADE them go step-by step along what they said they did, they got the same error I had been reporting.

Unfortunately the supervisor took no action and wrote it all off as "an honest mistake".
Just a note to follow up on my problem / solution. I installed the older version of the TWAIN driver today on the network that originally caused me the problems and everything is working great. I also did not have to run NetBEUI as Tech Services told me I would. I simply uninstalled the new version, then installed the older driver and everything worked like a charm. From now on, when I am involved in an installation, we install the software/drivers that come on the CD's that are included with the system. Live and Learn.

Thanks to all who provided insight and quick responses. You guys rock!


Add Reply

Link copied to your clipboard.